Receipts App Offline

ThurstonPrintThurstonPrint Member Posts: 4
I captured receipts with the iPhone Camera, it extracted data, but does not show the receipt and no matter what shows the status as “Offline” when connected by WiFi.
What’s going on?
Others have seen the same bug.
When wi this crucial step be fixed?


  • AlexLAlexL Administrator Posts: 2,869 admin

    Hi @ThurstonPrint . For first steps, we always recommend ensuring you're using our most up-top-date version of the app. To ensure you have it, just delete and re-download the app from the app store which will guarantee you have then newest version. If you're still having the same problem after doing so, feel free to reach back out.

  • stevemustevemu Member Posts: 1

    I can't find out how to capture receipts via my mobile. How do you do this?

  • ThurstonPrintThurstonPrint Member Posts: 4
    Same exact results after deleting Receipts app, reinstalled the app...shows “offline”.
    iPhone XS iOS 12.3.1 Receipts App 3.8.1.
    I wish you had ability to attach screen shots to show you what’s happening.
    When can a bug affix be expected?
  • MyronMyron Member Posts: 143 admin

    Hey @ThurstonPrint , thanks for the response! I am sorry to hear that your receipts app is still showing "offline". I would be happy to look into this further for you. I sent you an email to the email address listed on your profile. :smile:

  • SealCRSealCR Member Posts: 1

    @Myron I've completed the steps above re delete the app and reinstall from scratch and when I log in it still shows offline. This has been happening for months now! Are you fixing it or do I need to find an alternative provider?

    I'm using an iPhone SE iOS 12.3.1 and app version 3.8.1.

  • AlexLAlexL Administrator Posts: 2,869 admin

    Hi @SealCR . Please try logging out and logging back in as there's sometimes a disconnect between the online platform and the app. If that doesn't work, let us know.

  • JoeLibertyJoeLiberty Member Posts: 1

    Hi @Myron & @AlexL I've completed the steps above, deleting the app, then reinstalling it. Also tried logging out, then in again.

    However the Status remains unchanged 'Offline'. This has been happening for months.

    I'm using an iPhone6S iOS 13.3 and Wave app version

  • vanclarkvanclark Member Posts: 3
    Same issue here. Have reinstalled the app. Is this going to be solved or is it time to find an alternative?
  • EmmaPEmmaP Member Posts: 639 admin

    Hey @JoeLiberty and @vanclark! I'm sorry to hear about your issues with the app. Are you able to go to the settings menu for your device and check if all permissions are turned 'on' for the Receipts app?

  • dezeiler1_dezeiler1_ Member Posts: 2

    Hi, same issue here too... Just redownloaded and keeps on stating "offline"... Best, Matteo

  • vanclarkvanclark Member Posts: 3

    @EmmaP said:
    Hey @JoeLiberty and @vanclark! I'm sorry to hear about your issues with the app. Are you able to go to the settings menu for your device and check if all permissions are turned 'on' for the Receipts app?

    seems to be working ok now. thanks.

  • CarynCaryn Member Posts: 2

    Hi, having the same issue here, tried delete and reinstall the app, turn "on" all permissions in settings, still the same , "disconnect" .
    using Iphone 7

  • AlexLAlexL Administrator Posts: 2,869 admin

    Hi @dezeiler1_ + @Caryn , are you still seeing these same issues? Can you confirm that you are indeed connected to the internet? If you're connected through wi-fi, what happens when you disconnect and use data instead?

  • CarynCaryn Member Posts: 2
    @AlexL , thanks for the follow up ! Is working alright now , I’m with wifi connection.
  • dezeiler1_dezeiler1_ Member Posts: 2

    Hi @AlexL , indeed it is also working for me now, through a wifi connection...

  • Naha1Naha1 Member Posts: 1

    I had this problem but when I went to settings and turned all permissions on, including photos from “never” to “read and write” the offline went away.

  • ScottDodgeScottDodge Member Posts: 2
    I have cycled power to my phone, uninstalled and reinstalled the app, verified permissions and it still locks up. I get the offline note at the top, but it says it's been posted. The app completely locks up and has to be force closed. When I reopen it the receipt hasn't been posted
  • EmmaPEmmaP Member Posts: 639 admin

    Hi @Naha1! Thanks for letting us know your steps that seemed to resolve the issue!

    Hey @ScottDodge! Sorry to hear you're having trouble with this. Does this happen when you are connected to a cellular data or WiFi network, or both? To help us better understand the issues you are experiencing are you able to provide the following information: the version of the app you are using, the type of device you are using, some screenshots of the error you're seeing, and the operating system version?

  • ScottDodgeScottDodge Member Posts: 2
    Nope. Same problem
  • DupontoctaviusDupontoctavius Member Posts: 2

    I'm having the same issue. Have also deleted and restarted app/phone with no success

  • DupontoctaviusDupontoctavius Member Posts: 2

    I seem to have found a workaround. Turning off Cellular Data and forcing the app to only use Wifi seems to fix the syncing issue. I believe the app requires a certain amount of connectivity to work.

  • Kristian_GKristian_G Member Posts: 56 admin

    Hey @ScottDodge!

    Sorry to hear you're still experiencing the same issues with your app. I'd like to ask for some more detailed information from you to see if we can get this resolved for you, however, I think it might be best to do so via a support ticket, just because it'll allow you to send us some screenshots, etc.

    If you wouldn't mind, would you be able to open up a ticket and we can go from there? Feel free to include a reference to this thread for context!

    @Dupontoctavius nice workaround! Thanks for sharing that with us :)

    edited April 7, 2020
  • PollyPolly Member Posts: 3
    I’ve got this issue with the app too. I have deleted and reinstalled, tried disconnecting from WiFi as advised above and checked all permissions are on in settings but it still says offline and is not capturing image or info from receipts. Is there a problem? Anything else I can do? Thanks
  • ConnorMConnorM Member Posts: 1,229 ✭✭✭

    Hey @Polly! That's definitely a bit of an odd one. Are you still seeing these issues appearing? Can you let me know a little more about the device that you're attempting to access the Receipts app on?

  • PollyPolly Member Posts: 3
    Yes the issues still continue with the app. I’m using an IPhone 7 Plus and it is only recently that these issues started so not sure if it has something to do with an update or not?
  • AlexLAlexL Administrator Posts: 2,869 admin

    @Polly I can't say for sure but it may have to do with an update although I haven't seen any other complaints like such. Can you please try signing in and out of your account on the app as a last attempt to have it reconnect? If this doesn't work, you may have to email your receipts to Wave until the app starts working again.

  • PollyPolly Member Posts: 3
    @AlexL thanks. I will try that again (fingers crossed)
  • JamesB1JamesB1 Member Posts: 1

    My app is also not working - same problem with the "Offline" status. No receipts will upload online or sync with wave's online portal. It seems like the receipts app does not connect to the internet.

  • AlexLAlexL Administrator Posts: 2,869 admin

    Hey @JamesB1 , can you try following some of the steps that have been laid out previously in this thread? They are:
    1. Delete and re-download the app
    2. Sign in and out of your account

  • AppricodeAppricode Member Posts: 6

    If you are using an iPhone, reset the network settings work for me.

    Settings > General > Reset > Reset Network Settings

Sign In or Register to comment.