How to resume transaction imports on our new bank connection update



  • BlackRocketBlackRocket Member Posts: 1

    When I first got Wave several years ago the bank connection worked great. Then it stopped working about 8 months ago. I kept having to re-enter the two factor authentication process every time I tried to update the transactions. The process always seemed to work, (no errors from wave and no nasty emails from the credit union) but no transactions would flow from the credit union to Wave. I spent weeks with customer support, and the issue was never resolved. No errors, no data. So I was hopeful when I saw there was a new player in the game. Well, nothing has changed. I went through the process of outlined above, entered the user ID and password, then entered the TFA code sent to me by the credit union. Wave says I'm all set, no transactions moved to Wave. It is sort of sad that it used to work, now it does not, and no one seems to be able to tell me why.

    However, I can sympathize with Wave. They are providing a very useful service for free and trying to get data from organizations that are required to go out of their way to ensure that the data Wave wants is secure and protected. A classic example of conflicting goals. I'll just have to continue to upload bank statements, and hope that if the automated connection ever starts working that it does not create several thousand duplicate transactions. (yea, it did that once under the old provider and it took me a while to clean it all up)

  • UrbscaburbUrbscaburb Member Posts: 8

    Great, with the new data provider, half my accounts will not connect anymore! Please add BMO (US and CAN side) to your list of banks to reconnect.

  • FABcreatesFABcreates Member Posts: 3

    I agree with so many of the comments:
    1. major (Canadian) banks (eg TD, Tangerine) are not fully and correctly supported for the correct login access to BUSINESS accounts (only bringing up personal bank account options now) so the data aggregator doesn't seem all that competent.
    2. manual importing /manual refresh of bank connections (CRITICAL with this level of major update and bank connection incompatibilities - surely WAVE understood there were going to be many connection processes broken!)
    3. forcing us to move on your timetable and yet not doing any new development (like putting the BALANCE back on the dashboard) until every one is on the new system means that without live chat, many many small businesses are caught up in a wait for the fixes while running a company. I would pay for live chat to get things resolved that were working fine and to speed up the fixes.

  • Kyle_SC_53Kyle_SC_53 Member Posts: 1

    I can't upload anything other than a PDF. And, like others my bank has a personal and business login. The personal shows up in Wave but not the business. I need the business login.

  • ImpiraniImpirani Member Posts: 12

    @AlexL I'm with CIBC and since the following the bank feed changes, my deposits no longer show up in my account. Can you shed light on if this is a known issue with the connection for CIBC and an update how long should this will take to be resolved so I can see deposits flow through to Wave? I understand that each financial institution's connection is unique but if Wave is not compatible with CIBC (and doesn't plan to be) then I need to look for an alternative solution.

  • newreachnewreach Member Posts: 1

    this new feature set just dumped me out of a feature that was essential - you no longer connecting to my bank automatically as you did before has left me wanting to leave WAVE. uploading manually through google connect is not time efficient

  • AlexLAlexL Member Posts: 2,869 ✭✭✭

    @bootz42 we definitely accept .csv format, and checking out Wave Connect might make the manual import process a lot easier for you as well.

    @Cellc I am noticing a lot of different Peoples Bank connections that are location based. Try typing in Peoples Back Business to take a look at all of the connections that pop up. If none of these work, it's definitely possible that the Peoples Bank Business connection isn't currently supported, and that you should use Wave Connect to get your transactions into Wave until our data aggregator supports the connection.

    @dmbirgy Who are you banking with?

    @bookkeepinghell have you tried searching for the line of credit accounts under the connect a bank section? Some of the accounts that used to be included under one connection are still supported, but they're just separated amongst different connections now.

    @Revival_Renovations which account do you want it to be importing into and where is it importing at the moment?

    edited January 6, 2020
  • TomCooperTomCooper Member Posts: 14

    I'm trying to "unpause" transactions to my bank (Pinnacle Financial Partners) - which purports to be supported. I enter my username and my password correctly (tried multiple times, confirmed via web login that my account was not locked and the username/password is working.)

    I got the attached errors - and live chat and help center are both not online/working.

    Ideas? I was able to resume transactions with Chase - so I think I "get" how to do it...

  • TomCooperTomCooper Member Posts: 14

    I'm wondering if the username is being sent to pnfp as lower case. Their usernames are DEFINITELY case sensitive. I just tried to unpause my personal account with them, and got the same error that I did with my business account.

  • AlexLAlexL Member Posts: 2,869 ✭✭✭

    @Urbscaburb BMO is supported although it looks like they are experiencing an outage. This should be back up and running as soon as our data aggregator has provided a fix.

    @Kyle_SC_53 Try using Tabula to get your PDFs into csv files which are compatible with the manual upload.

    @Impirani Looks like CIBC is experiencing a temporary outage. This means that our data aggregator is aware of the issue and should be working on implementing a fix to have it up and running again soon.

    @TomCooper Have you had any success with the connection yet? Can you try connecting while using incognito mode in Chrome to see if that helps?

    edited January 6, 2020
  • Revival_RenovationsRevival_Renovations Member Posts: 4

    @AlexL said:

    @Revival_Renovations which account do you want it to be importing into and where is it importing at the moment?

    Hi @AlexL, I'm trying to import into an account on Wave that I've called Libro. The thing is, when I go to import, it gives me all of ONE choice: PayPal, which isn't even an account I ever use. The one I need isn't even listed.

    My Options:

    But that's the thing...I have plenty of accounts. The ones I'm trying to connect to is called Libro.

    My actual Accounts:

  • bronwynrhbronwynrh Member Posts: 3

    I'm having the same problem as @TomCooper, with Republic Bank and Trust.

  • UrbscaburbUrbscaburb Member Posts: 8

    @AlexL I'm having the same issue as Revival, trying to reconnect my BMO Mastercard/LOC. It doesn't give me the option to attach to the existing account that it's always imported into.

  • BarsinBarsin Member, Moderator Posts: 2,041 ✭✭✭

    @TomCooper @bronwynrh Typically with a plaid error in credentials, it usually means that you're selecting incorrect bank connection from the page. I understand that PNFP in Tom's instance has two connections, and PNFP umbrella connection, and a PNFP Tennessee connection. It's likely that your bank's connection is specific to a region that our aggregator does not support at this time. If so my apologies for this! Otherwise ensure that your typing in your credentials exactly as they appear in your bank login.

    @Revival_Renovations @Urbscaburb In this case, I don't think you will be able to connect them to an existing account. Your new connection is trying to create a new account in your CoA. So what I would do at this point is create a new account (make sure it has a unique name, perhaps add an asterisk* beside the newly created account. Edit the date to import only the transactions from the latest available transaction in your former Libro account. Then head into your transactions page, filter the account to pull up the former Libro transactions and move them into the newly created Libro account. You can use our bulk edit tool to move these to a new account.

  • TomCooperTomCooper Member Posts: 14

    @BarsinA I am certain that I am typing in my credentials correctly for pnfp.

    With Pinnacle, I am in "the Carolinas" and there was a recent change (12 November) to the Pinnacle online banking system to merge all account holders under one online banking system.
    The login for that starts at and redirects to

    Is there any way to know whether/when support for Pinnacle may be available with this new integrator? Are there any technical details that I can provide to them to speed up the process?

    edited January 7, 2020
  • Revival_RenovationsRevival_Renovations Member Posts: 4

    @Revival_Renovations @Urbscaburb In this case, I don't think you will be able to connect them to an existing account. Your new connection is trying to create a new account in your CoA. So what I would do at this point is create a new account (make sure it has a unique name, perhaps add an asterisk* beside the newly created account. Edit the date to import only the transactions from the latest available transaction in your former Libro account. Then head into your transactions page, filter the account to pull up the former Libro transactions and move them into the newly created Libro account. You can use our bulk edit tool to move these to a new account.

    Sounded great in theory. Doesn't work exactly how you suggested. First, it wouldn't allow me to import into a newly created account (so now I have a random account floating in there that I can't get rid of...but doesn't seem like too big of a deal)

    But the big problem - it won't let me bulk import from that account. It tells me 'you have 5 transactions that cannot be moved'. It doesn't tell me what transactions

  • Scott_McCullochScott_McCulloch Member Posts: 2

    Like @TomCooper my bank is Pinnacle Financial Partners (PNFP), and like @TomCooper I can't "resume" the connection to my bank accounts... I have confirmed that I'm using the correct login credentials by logging into the PNFP site directly, but keep getting the error message when I try to "resume" that my connection.

    I can confirm also that the Waveapps connection to my PNFP account was fine after reconnecting following the changes to the PNFP web platform in November (i.e., I had to reconnect after the Nov. changes to the pnfp system, and it was working fine).

    So, I'm guessing the response from @BarsinA means I'm (we're) out of luck until the new aggregator fixes this to accommodate the different regions.

    Major inconvenience. :(

    edited January 8, 2020
  • mjhmjh Member Posts: 9 admin


    Hello and thanks for your feedback. With our new bank data provider, they get transactions from your bank at certain intervals, depending on the bank. With yours, RBC and AMEX, it should be often.

    When our bank data provider receives transactions, they immediately send them to Wave. A refresh button would not have the ability to query your bank and get the latest transactions. Your bank sends them to our bank data provider as soon as they are available, and they are immediately sent to us.
    I am sorry to hear that you have not had an update in over 2 days. This is not a normal situation. If you experience this, you can open a support request and we can do some work on our end to ask our bank data provider to investigate why there is such a long delay.

    Our bank data provider receives transactions on a certain interval, therefore deleting and reconnecting and toggling the ON/OFF button will not force a refresh.

  • Maximum365Maximum365 Member Posts: 5

    Hi Wave Support.
    Like others, the change of Data Provider has caused me grief.
    1)When I resumed the paused connection, I had duplicate entries all the way back to beginning of November that I just finished clearing up.
    2)I also add an Investment Account linked to a Wave Long Term Asset Account which has simply disappeared, along with its balance.
    3) I tried to create a new account to link with my financial institution and the options are for Cash and Bank, Credit Card and Loan & Line of Credits.
    Will it be possible again to link Investment Accounts in the near future?

  • mjhmjh Member Posts: 9 admin

    Adding back the banking accounts balance to the Dashboard is next on our priority list.

  • daHawaiianStoredaHawaiianStore Member Posts: 3

    I'm having the same issues as others, getting various error messages on many of the accounts that I'm trying to resume. Even AMEX--is that not supported? Paypal? Venmo? All of my Credit Union Accounts? I have gone back in on multiple days hoping it was just a glitch, but this appears to be a widespread issue. The manual import is not a good solution, far too time-consuming when you have many accounts and multiple businesses. Is that even an option when you can't get the account to even resume? Other accounts had to be set up as though they were new accounts. Does this mean all of the past work categorizing things will have to start over as well? I am beyond frustrated...if the platform doesn't support my main bank accounts, it looks like I'll have no option but to go back to Quick Books. I wouldn't have wasted all of the time I did setting this up if those accounts weren't supported in the first place. The old platform worked's another unfortunate case where fixing something that wasn't broken, created a mess.

    edited January 12, 2020
  • Just_LurkingJust_Lurking Member Posts: 31 ✭✭

    Ironic that Bank of America is one of the listed banks in the example screenshot above. My BofA account will not add, saying that MFA (Multi-Factor Authentication) is not supported. I know for a fact that Plaid supports MFA accounts (shouldn't everyone have MFA turned on these days?) Is this just a temporary glitch? Anyone else having issues adding accounts that have MFA (AKA 2-factor authentication)?

    edited January 9, 2020
  • FitmanNJFitmanNJ Member Posts: 2

    @Just_Lurking : Yes, I can't get even one of my accounts to re-connect, including my Bank of America Business Account, which generated the same error message as for you ("...MFA not supported."). Also, I agree that all of the security experts are recommending MFA, including Dashlane, my password management program. I'm VERY disappointed regarding how this is going!

  • davearonsondavearonson Member Posts: 3

    Looking for info why THE ONE AND ONLY ACCOUNT I REALLY NEED WAVE TO HANDLE IS NO LONGER IN THE LIST OF ACCOUNTS that my bank lists for me! Someone, whether Wave, Yodlee, or my bank, totally dropped the ball, and MY ACCOUNTING IS DEAD IN THE WATER! I've heard NOTHING from Wave about this.

  • davearonsondavearonson Member Posts: 3

    @KevinS said:
    not all my accounts are appearing as being available.

    I'm having exactly this problem now, with Northwest Federal Credit Union.

  • RobMMRobMM Member Posts: 1

    hmmm.... exact same issue as all.... the 4 year familiar account to resume the verified Bank import into is entirely missing! The drop down doesn't give any relief as the account is not there to select. Only option is to select 'new', and that's just not right. Do we all just wait this out and hope for system eventual recovery??

  • Just_LurkingJust_Lurking Member Posts: 31 ✭✭

    @Mani Sorry to bother, but any chance you can weigh in on this, or whomever is responsible for data connections? I don't know what percentage of folks have been converted to using Plaid as the data aggregator, but it seems to be a bit of a train wreck for many. Is there any chance of rolling back to the previous data aggregator while these issues are (hopefully) resolved?

    In my case, something as simple as two-factor authentication not being supported at BofA, with their 70 million customers, strikes me as ludicrous. That alone should be a deal breaker for Plaid.

  • disappointed808disappointed808 Member Posts: 4

    I've been on the phone with Intuit trying to set up an account with them instead, due to this comically bad integration upgrade.

    • Double entries
    • No manual refresh
    • Wrong entries when it did sync (the one time its synced)

    Related to the manual refresh: In the past, when there were posted transactions in my account with Bank of America, a manual refresh would immediately and without fail (ever) bring those new transactions in. Now, nothing.

    While trying to set up my account with Intuit (Quickbooks), they've screwed up my account process, triple charged me, and my account is in a frozen state while techs and their accounting team look into it. I'd rather deal with that than with the new changes from Wave. That's how much I hate this new integrator and dashboard change.

  • kmartinkmartin Member Posts: 10

    I work a full time 50 hour a week job, plus run my own business. Every day i manually refresh my bank to pull in transactions, i review them every single day. This allows me to stay on top of things and not get behind.

    NOW I reconnected my bank successfully, but it is NOT IMPORTING MY TRANSACTIONS. It pulls the balance, but wont bring the transactions in. I CAN CHECK THE BALANCE WITH MY BANKS APP FASTER.

    You guys screwed the system up last year at tax time, where expenses werent showing properly. That sure made estimated taxes easy.......not

    Now this year you screw up the bank transactions. So now i have to manually enter them...If i have to MANUALLY ENTER THEM THEN WHAT IS THE POINT?????

    I use the credit card processing, but i would be more than happy to not use anything at all and start using a PEN AND PAPER AGAIN.

  • mjhmjh Member Posts: 9 admin

    If you are not seeing an account to import into in the dropdown, the reason may be it is not of the same type for example, "Checking accounts" and "Savings accounts" can only import into accounts under "Assets - Cash and Bank" in your Chart of Accounts. Another reason may be that the account is already connected to a bank account. A Chart of Account cannot be connected to 2 bank accounts. Please see if that helps with your issue.

    Unfortunately we are not able to roll back to the previous bank data provider. Our new bank data provider does support Bank of America, and they support MFA with them. It may be possible that there are multiple types of MFA that Bank of America provides, and some of those types may be incompatible.

    The reason we don't have a manual refresh with our new bank data provider is they send us transactions as soon as they are available. There is never a time when our bank data provider has transactions, that we don't have in Wave. With our old bank data provider, they would collect transactions and wait for us to fetch them. This step is no longer the case.
    Neither the old or new bank data provider has the ability to query your bank directly for new transactions.

This discussion has been closed.