Unable to Import (any) Bank Account Statements

PeacockSolutionsPeacockSolutions Member Posts: 3


Previously I have done my accounting by hand with Excel but I want to move over to Wave.

However, I'm stuck with trying to import my bank account statements.

I first tried to connect my bank account (BNZ Business) but after entering my details and clicking the "connect" button, nothing happens. I have tried this on multiple browsers, computers, and networks. This may be because BNZ now enforces 2FA.

Accepting defeat, I then tried to manually import my statements, but this is not working either:

No matter what file type I use, and no matter what web browser I use, I receive the error message:

"Something went wrong with your file upload. Try confirming that the file type is an accepted file type."

I even tried using the csv template to make a "test" document with really simple information, but I still receive this error message.

Do you know how I can resolve this?

Kind Regards,



  • CharlotteCharlotte Member Posts: 695 admin

    Hi @PeacockSolutions thanks for reaching out! Could you try uploading your sheet to a Google Sheet, redownloading as a CSV, and letting us know whether this works? If it doesn't, could you also confirm the columns you currently have in your doc?

  • tekfranztekfranz Member Posts: 14

    The Google Sheets Trick worked great Thanks so much!
    I too was struggling with this having formatted and reformatted the Spreadsheets multiple times

  • PeacockSolutionsPeacockSolutions Member Posts: 3

    Hi Charlotte,

    I tried that tip but unfortunately it did not fix anything. I tried it again with two separate files, the first is the default csv from my bank that has the following columns:

    Date, Amount, Payee, Particulars, Code, Reference, Tran Type

    After that failed, I tried again with the template file provided by Wave, limiting myself to just the 3 column version of that document, but again it would not work (even after uploading to Drive, turning into a sheet, and redownloading).

    Same error again in all cases: ""Something went wrong with your file upload. Try confirming that the file type is an accepted file type." And it is repeatable on multiple computers and networks.

  • NickPrestaNickPresta Administrator Posts: 3 admin

    Hi @PeacockSolutions As far as we can tell, there seems to be an issue with the connection between New Zealand and the part of Wave that processes your bank statement uploads. The same sort of issue also seems to occur when you try to connect your bank account (BNZ) which is why clicking on the Connect button looks like nothing is happening. We've opened a support issue with our network vendor and expect to hear a response back very soon.

    As a workaround in the meantime, if you have the ability to connect to Wave through a VPN in another location (Canada or the US work best), you will be able to connect and upload a bank statement (or connect your account).

    We will update this thread when we know more. Apologies for the frustration.

  • IvanIvan Member Posts: 1

    Hi team,

    I am also experiencing this issue with BNZ statement upload from New Zealand. What is the latest update on this?

    Many thanks

  • CharlotteCharlotte Member Posts: 695 admin

    Hi @Ivan thanks for getting in touch. At the moment, we're still investigating this issue. The workaround is to use a VPN to set yourself to another location and then you'll be able to upload successfully. I totally understand that this isn't ideal, and we'll keep digging and share more updates if and when they're available. Appreciate any patience you can extend our way in the meantime.

  • YkingYking Member Posts: 18

    Hi team ,
    Is there a possibility to link my bank account (kuwait) with wave accounting software?

  • Ryan_WRyan_W Administrator Posts: 460 admin

    @yousuf does your bank account appear in the dropdown menu at Banking > Bank Connections when you search for it? If not, it means it's not supported and you'll need to upload your statements instead. You can also submit a request to have your bank supported from the "can't find your bank?" prompt.

    Of course, if your bank appears there, just follow the steps to verify the connection and you're good to go!

  • YkingYking Member Posts: 18

    Thanks for your reply

  • trcltrcl Member Posts: 2

    Yes, I am located in New Zealand and have been getting the same error message since last year. It was working well before that and we were very happy with Wave. Actually, it started working again a few months ago, and now not! Looking forward to the fix. Thanks.

  • CharlotteCharlotte Member Posts: 695 admin

    Thanks for your patience @trcl please don't hesitate to join other conversations in the meantime, or to let us know if there is anything else our team might be able to assist with.

  • Pat_NZPat_NZ Member Posts: 2

    @Charlotte @NickPresta - Unfortunately I'm another victim to this problem. I bank with ANZ from within NZ. Same issue. Was working and now it's not. Just confirming that it's not an isolated BNZ issue. Thanks

  • SimonESimonE Member Posts: 2

    @Charlotte @NickPresta @Pat_NZ Similar problem here, trying to link to Westpac Online (NZ) bank accounts from NZ.

  • Pat_NZPat_NZ Member Posts: 2
    @SimonE using chrome Dev tools I could see that when initiating a connection from within NZ there was a DNS error causing the issue. I have a VPN for many other reasons so established a VPN to the UK (by default) and also ran into slightly different issues there. Finally, I established a VPN to the US and had no issues.

    Interestingly this service used to work perfectly. I just can't pinpoint when the problem was introduced.
  • SimonESimonE Member Posts: 2

    BTW, what was the response from your network vendor? Are they blacklisting New Zealand IP addresses or something?

Sign In or Register to comment.