502 error

PierrottPierrott Member Posts: 1

I upgraded from El Cap to High Sierra. I get a 502 from Wave. Do you see me as a new machine? Because I can sign in. I just cant access my invoices...

edited March 8, 2018 in Technical Support


  • AlexiaAlexia Administrator Posts: 3,314 admin

    Hi @Pierrott! It shouldn't matter, you should be able to access your invoices regardless.

    Have you tried clearing the cache for your browser? Or using a different browser altogether? Chrome and Firefox tend to be the most stable ones.

  • DanWinDanWin Member Posts: 10

    I have exactly the same issue. Tried to access on Firefox, Chrome, Internet Explorer and also on Chrome/Android on my phone but always get the strange Cloudflare captcha page on visiting Waveapps.com and then whenever I try to click on Invoices I get the 502 error as follows:

    Wipeout! Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

    Use your browser's back button or one of the following links to help you on your way:

    Please help as this has happened before and obviously an ongoing issue with Waveapps.

  • DanWinDanWin Member Posts: 10

    I should also note I have also tried another computer here also and same issue presents itself.

  • CharlotteCharlotte Member Posts: 695 admin

    Hi @DanWin ! At this time we are not experiencing any issues of this nature on our end. I can say with complete confidence that, were there reports of an ongoing or widespread issue preventing access to Wave, our team would be on it. We understand that it's important for you to be able to work on schedule, and interruptions to that schedule are extremely serious for us. We do our best to avoid downtime because the ability of our customers to work is the core of our business. If the root cause of such an issue is on our end, you are likely to see a large number reports here and on Wave's social media profiles within the same short window of time (many reports within a few minutes or less).

    Inability to access Wave can happen for different reasons that are not Wave bugs or issues. If you take a look at similar reports, many people choose not to follow up because the issue was shortlived. This indicates the possibility that it is caused by something like this. That is, a service utilized by Wave experienced slow-down, for example.

    While it's true that 502 errors can occur because of server issues on a given website, they can also occur because your browser thinks there are server issues but in actuality, you are experiencing a problem with your browser, a problem with your networking setup, etc.

    Besides clearing your browser's cache and/or hard refreshing, you might also try restarting your computer, your networking equipment, or changing your DNS settings.

    In my experience, a probable cause is network issues. To test this, attempt to access the same page within the same account using data on your mobile device rather than your usual wifi network, or a network other than the one you typically use and/or disable (or enable!) your VPN, if using (a mobile device using data is usually the easiest test). If this works, you may want to contact your network administrator or review your connection settings.

    Please do let us know if you try these steps!

    edited February 8, 2018
  • DanWinDanWin Member Posts: 10

    Thanks for the reply, what sort of changes can I implement to my router/modem to set things up any differently? This isn't the first time this has happened. Maybe 2-3 weeks ago and a similar thing came and restricted access to the Invoices and Recurring invoicing section for about 4-5 days and then it magically fixed itself!

    I don't have access at the moment to mobile data to test your theory from another connection but have noticed a few reporting similar problems of late.

  • DanWinDanWin Member Posts: 10

    Cloudflare support state that these issues are generally related to:

    In most cases, a 502/504 error happens because your origin server (e.g. your web host) is returning this code to us, and Cloudflare returns this code in turn to your visitors.

    Who is in control of the origin server? Waveapps? That was the error initially from Waveapps... Wipeout! Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.

  • DanWinDanWin Member Posts: 10

    Hi @Charlotte I believe this has to do with a Cloudflare problem, even though they seem to point the finger at the Waveapps website. I've been down the road of the ISP also and they claim there is nothing they can do either. Thoughts?

  • DanWinDanWin Member Posts: 10

    Am I able to send my IP to Waveapps to ensure it is whitelisted on Cloudflare? I can PM this if this will correct my access restriction.

  • CharlotteCharlotte Member Posts: 695 admin

    Hi @DanWin is there a Ray ID in the error message you receive? If so, can you send as well?

  • DanWinDanWin Member Posts: 10

    Hi @Charlotte have you had any luck with this whitelist?

  • CharlotteCharlotte Member Posts: 695 admin

    @DanWin I have checked and there is no record in our system of Clouldflare blocking your IP, or of either of the IDs provided. I suspect it is a network issue so I would recommend rebooting your networking equipment, testing on another network, changing your DNS settings, or attempting to access Wave via a VPN.

  • DanWinDanWin Member Posts: 10

    Thanks @Charlotte but I'm not really sure what DNS settings I can change. I've rebooted the modem about 5 times and my ISP has said it is nothing to do with them as I can ping the sites I'm having difficulty accessing.

  • CharlotteCharlotte Member Posts: 695 admin

    @DanWin can you perhaps try using a VPN or on another network? This would help to rule this out. I can circle back with our engineers and other members of my team but this doesn't appear to be being caused by anything on our end. My suggestions are based on things I've seen work in the past.

  • DanWinDanWin Member Posts: 10

    Thanks @Charlotte but upon having my IP changed by the ISP the problem has returned... I'm lost now :(

  • DanWinDanWin Member Posts: 10

    Hi @Charlotte did you get my inbox?

  • bermanacbermanac Member Posts: 1

    I am having same issues. Every time I click on Accounting - Transactions: Keep getting Wipeout 502 error:

    Wipeout! Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded, etc.
    Use your browser's back button or one of the following links to help you on your way:

    Wave home page
    New user? Sign up for an account!
    Existing user? Sign in.

    edited February 20, 2018
  • dougsssdougsss Member Posts: 1

    I'm having this exact same issue as well in Chrome and Firefox. I can't create any new invoices. Creating a New Customer is broken to, changes I make won't stick. Recently upgraded to High Sierra OS from El Cap. Not sure if related at all.

    Screenshot: http://prntscr.com/ihjh5f

    edited February 20, 2018
  • HelpAfricanChildrenHelpAfricanChildren Member Posts: 1


    I am experiencing the same issue so just came to add my voice, I have seen several forums with this topic, Charlotte comments on each of them that it is not a widespread issue. I just want to know how many people need to report this problem for it to be seen as such.

    I am waiting in great anticipation and enormous frustration whilst trying everyones suggestions to no avail.

  • rik_08rik_08 Member Posts: 6

    Hi all,

    We have experiencing the same 502 'wipeout' issues too!
    the situation is: everything works fine when we are at office.
    However, as soon as we arrived home. the same laptop (using home network) is having issue. You can still login, access all other sections (accounting / reports etc). but once you click 'invoice', or 'recurring invoice'. you are wipeout out!!!

    Saying request has been terminated... same error message as above...

    It doesn't make any sense? We have never experienced similar problem for any other website but WAVE..

    Please can the technical team look into this??? many thanks!!
    We will be waiting feedback here.


  • rik_08rik_08 Member Posts: 6


    issue details (English is not my first language, but i will try my best)

    • When we use Wave at office - no problem
    • When we use Wave at home, i can still login to my account, but as long as you click 'invoice' or 'recurring invoice', it kicked you out.
    • 502 error msg reads like this: Wipeout! request has been terminated possible causes: the network is offline; Origin is not allowed by Access-Control-Allow-Origin; the page is being unloaded, etc.
    • i have spoken to my ISP, but they really have no idea, the only thing they could do is to re-bot the router which is not working to resolve this problem.

    Can the Wave technical team look into this please and advise at your earliest convenience.
    many thanks!

    edited March 8, 2018
  • rik_08rik_08 Member Posts: 6

    Any feedback from the WAVE team??

  • AlexiaAlexia Administrator Posts: 3,314 admin

    Hi @bermanac, @dougsss, @HelpAfricanChildren, @rik_08

    Are you still experiencing those issues?

    Most of the time, if a 502 error isn't affecting absolutely every user, it's a browser or a networking issue.

    The easiest way to check if this is an issue with your home network or with Wave is to try to log on to the Wave website on a mobile device connected to a data network (and not your wi-fi).

    The first troubleshooting step you'll have to go through is clearing your cache and cookies. It's a small thing, but it often fixes this kind of issue. You should also try logging into your Wave account with Chrome in incognito mode.

    If that doesn't work, you'll want to try and reset your modem and your router. To do this, unplug your modem and router from their power supply for 10-20 seconds, and then plug them back in. It might take a few minutes for everything to go back online.

    Let me know if that fixes the problem.

  • CharlotteCharlotte Member Posts: 695 admin

    @HelpAfricanChildren thanks for following up with us. I apologize if my responses have been unclear or if it has appeared to you that I've been attempting to deflect your issue. We absolutely want you to be able to access your account -- your success is our success!

    To clarify, the earlier posts in this discussion that you reference all occurred at various dates and times, often days apart. If Wave were down, you would see an influx of Wave users reporting this issue at once and we would see internal indicators letting us know this is happening.

    I've investigated for each person who has posted here and I can confirm that I see nothing indicating that you're being blocked by Wave or any other issues that should prevent access.

    Given this, our next step is to examine other possibilities. The first step is to try to determine the cause. As @Alexia says, please take a moment to attempt the same action using data or another wifi network. If you're successful we can take a look at troubleshooting procedures to resolve network issues. Thank you!

  • rik_08rik_08 Member Posts: 6

    Hi Alexia&Charlotte,

    Thanks for the feedback. I have tried to login WAVE through mobile device (to connect my laptop via iPhone's hotspot), and it worked. As soon as I switched back to home wifi, the same issue occurs. So for my case, I can almost tell that it is a network problem. I have then contacted my ISP, however, they did look into this but still couldn't fix the problem as yet.
    I have also in the meantime tried to clear the cache and cookies/ reset the router. but not working.
    But I haven't try to login with Chrome in incognito mode. I will try this and let you know if it works.
    Thank for for your help so far!
    Kind Regards,

  • AlexiaAlexia Administrator Posts: 3,314 admin

    Hi @rik_08, that tells us that the problem is with your network. Have you tried restarting your modem and router? That might fix the issue.

  • rik_08rik_08 Member Posts: 6

    Hi All, my '502 issue' has finally solved, website is now opened with no problem! Contact your ISP, tell them the situation, they are the right people to fix 95% of these issues. hope this helps.

  • AlexiaAlexia Administrator Posts: 3,314 admin

    Really happy to hear that, @rik_08!

  • NewGen_CreativeNewGen_Creative Member Posts: 1

    Just started getting the 502 Error this morning. Tried on every browser from PC to iPad, getting the same issue! Tried all browsers and still no luck! Cleared history, cookies and cache....any suggestions? Also tried on my phone network....same issue

    edited March 20, 2018
  • Associated_GraphicsAssociated_Graphics Member Posts: 0

    Site down, offline mode should be a thing.

  • kbc05kbc05 Member Posts: 0


    It looks like the software isn't working at the moment with errors every time I click in.

    Thanks for your help

Sign In or Register to comment.