Wave Connect - Not Connecting Google Sheets

oursteve1oursteve1 Member Posts: 2

Hi, I've used the integration feature to add google sheets. I've followed the requests and allowed Wave Connect to connect with my Google account, I even get an email telling me its connected from Google, yet when I try to use the app. nothing happens and I go through connecting all over again, and again etc. Is there a cure out there please. Steve

Comments

  • oursteve1oursteve1 Member Posts: 2

    Hi, Please note I have sorted this myself. All to do with the Google Account.

  • DanielGTDanielGT Member Posts: 9

    @oursteve1 I've have a similar problem, I can donwload, but can not Upload, can you explain me what did you do, or find out with your account. So far I haven't been helped at all. thanks.

  • AlexLAlexL Administrator Posts: 2,869 admin

    Hi @DanielGT . What issues are you having when trying to upload? Feel free to go into some further detail so we can try and troubleshoot the issue for you.

  • teegytuftyteegytufty Member Posts: 4

    I'm having this issue, I've uninstalled and reconnected, shut down and rebooted still no resolution. Would love to know the google issue you corrected

  • j31029j31029 Member Posts: 2

    Same here. I get the error below on browser console.

    Uncaught  at UploadObjects:510 (Wave Connect:16) 1601e60f-e6dd-4afe-adca-a24befa0d81d
     at UploadObjects:468 (Wave Connect:16) 1601e60f-e6dd-4afe-adca-a24befa0d81d
     at UploadObjects:456 (Wave Connect:16) 1601e60f-e6dd-4afe-adca-a24befa0d81d
     at Upload:1177 (Wave Connect:16) bc28999c-5187-43dc-9c84-93b4f4e2aba7
     at dataValidateOrUpload_ (Upload:1173) (Wave Connect:16) bc28999c-5187-43dc-9c84-93b4f4e2aba7
     at validateData (Code:285) (Wave Connect:16) aa63046e-6afb-4b08-9e64-4fd35a718287
    Access to XMLHttpRequest at 'https://play.google.com/log?format=json&hasfast=true&authuser=0' from origin 'https://docs.google.com' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.
    play.google.com/log?format=json&hasfast=true&authuser=0:1 Failed to load resource: net::ERR_FAILED
    
  • AlexLAlexL Administrator Posts: 2,869 admin

    Hey @teegytufty , what exactly is the issue you're having? Are you seeing an error message at all? Any further info would be super helpful.

    Hi @j31029 , what browser are you accessing Wave Connect from? Can you try using a different browser (Firefox or Chrome for example).

  • j31029j31029 Member Posts: 2

    @AlexL I am using Chrome. I don't have other browser unfortunately.

  • AlexLAlexL Administrator Posts: 2,869 admin

    @j31029 are you able to download Firefox to give it a try? This will give us a good idea of it's a browser issue or not.

  • JorJor Member Posts: 1

    @AlexL I'm also having the same issue UploadObjects:510 error in Chrome when trying to validate input from Google Sheets spreadsheet that was working before. Any idea if it's a browser issue? Just tried MS Edge and Firefox. Edge gives the same error. Firefox gives a different error but also fails to validate the input sheet.

    edited December 1, 2020
  • NedryNedry Member Posts: 1

    Well, I'll jump in here since I'm having the same issue and it appears nobody has followed this all the way through.

    I'm able to connect to Wave Connect. I can download data with no problems. When I try to upload, I'm able to "prepare" the input sheet. That works fine. When I try to validate the data, I get the blue boxes that show something is happening... but it never finishes and I never get any kind of error message. The progress indicators just keep "spinning". I tried skipping that step and going right to upload and the same thing happens there. I've let it run for about 10 min and nothing happens.

    I'm running the latest version of Chrome on a Mac, but have also tried the latest version of Firefox. So it doesn't appear to be a browser issue...

  • firemeatswood1firemeatswood1 Member Posts: 1

    If you have signed in with multiple gmail accounts in your web browser and try to use any G Suite add-on, you might see this error: drive.google.com refused to connect. Please open an incognito window, sign in with your gmail account used to install the add-on (make sure that you haven't signed in with any other gmail account) and try to use the add-on. It should work.
    "drive.google.com refused to connect" error when trying to use the add-on while I've signed in with multiple gmail accounts in my web browser

Sign In or Register to comment.