Dashboard won't load properly since new website.

SophieLouiseSophieLouise Member Posts: 2

I have been using Wave for awhile now and ever since the new changes to the website my dashboard never fully loads. I cannot see my cash flow, profit and loss, net income etc. There is only blue loading circles in each section. Strangely I can see the overdue invoices and bills section, but that's all. I have tried using different web browsers and updating my software, but still no change.

Also I tried to send this through submit a request but that page cuts off down the left hand side so I can't see/use the ReCaptcha verification so I can't actually submit my request!!!!

Any help would be amazing!! Thanks!

Comments

  • JamieDJamieD Administrator Posts: 1,145 admin

    Hey @SophieLouise. Wave functions on the latest versions of Chrome and Firefox (so please make sure you are currently using those browsers). If you are, one thing that I suggest doing is clearing your cached data/cookies. This should help resolve the issue that you are currently experiencing in terms of the page not fully loading. Also, if you are still experiencing this problem once you have cleared the cached data/cookies -- please try an incognito browser to see if that resolves the problem.

  • RebeccaSRebeccaS Member Posts: 1

    I'm having the same issue. I updated chrome, cleared cookies etc. and tried on an Incognito window and nothing worked.

  • AlexLAlexL Administrator Posts: 1,794 admin

    Hey @RebeccaS , can you send us a screenshot of what this looks like from your end? Is there anything specifically that isn't showing up? Any further info so we can help you troubleshoot would be fantastic!

    edited July 15, 2020
Sign In or Register to comment.