OAuth API connection error

Viet_Accounting247Viet_Accounting247 Member Posts: 3

I'm trying to connect to Wave using OAuth2 but keep getting this error after signing in:

Something is broken on this page
Our technical team has been alerted and is working on a solution
Error code: e672b32303d04063b2c95b0e30ecaa49

Could you please check if the connection is still working fine?

Tagged:

Comments

  • dacklanddackland Member, Moderator Posts: 15 admin

    Hello, @Viet_Accounting247 ,

    Could you provide a few details on what steps you're following? There are a few ways we use OAuth, including:
    1. Authorizing your custom application to access user data, following this guide.
    2. Signing into Wave directly via the "Sign in with Google" option.
    3. Authorizing one of our integrations such as Wave Connect or our Zapier integration to access user data.

    If you are following the OAuth guide to allow your application access to user data, have you tried opening the devtool console? It can sometimes provide insight into the cause of the error, such as an invalid scope.

    Either way, the OAuth flow is working well for me, so more details on the steps you're taking would help narrow down the problem :smile:

  • Viet_Accounting247Viet_Accounting247 Member Posts: 3

    Thank you so much for your detailed response @dackland . I managed to use devtool console to troubleshoot this and found out it was because I haven't put 'scope' in. I have made some progress but then got stuck again. The new error is as below:

    I have been using Bubble.io to create OAuth2 flow to Waveapps with below setup. So this might be a question to bubble. If you are not sure, it's totally fine.

    One issue I could think of is because of missing User Profile Endpoint which I couldn't find anywhere on Waveapps API Documentation. Is there such an endpoint with Waveapps?

    Thank you!

  • dacklanddackland Member, Moderator Posts: 15 admin

    One step closer! The error from Bubble.io suggests there's no access_token, but it's present in the raw response. Have you tried un-checking the "Token is returned as querystring" option? If that doesn't work, it might be worth contacting Bubble for support, since Wave seems to be returning the correct info.

  • Viet_Accounting247Viet_Accounting247 Member Posts: 3

    Thanks for your comment @dackland . I have sorted this issue and managed to connect to Waveapps fine. I think there is some issue with Bubble predesigned OAuth2 User-Agent flow, in particular about user profile end-point. I had to create a manual authorization workflow with each step broken down rather using the provided flow.

Sign In or Register to comment.